$re = '/\/var\/log\/opscode\/(?<desired_courcetype>[^\/]*)/';
$str = ' /var/log/opscode/desired_sourcetype/current.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);