re = /(?<=Keyword1:)(.*)(?=Keyword2)/m
str = '"Keyword1: That text I want \\r\\n Keyword2: Value2 \\r\\n Keyword3: Value3 \\r\\n Keyword4: Value4"
"Keyword1: That text I want Keyword2: Value2 \\r\\n Keyword3: Value3 \\r\\n Keyword4: Value4"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end