$re = '/((?<!\w)-|-(?!\w))/m';
$str = '--good
-good
g-ood*
g--ood
good-
good--
-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);