$re = '/(?P<prop>[\w-]+) # property name
(?P<prop_params>; # property params, e.g. dstparams
( [\w/,-]+(=[\w/,-]+)?) # first param key[=val] element
(;[\w/,-]+(=[\w/,-]+)?)* # additional key[=val] elements
)?: # colon separator between prop and main params
(?P<params> # main params
( [\w/,-]+(=[\w/,-]+)?) # first param key[=val] element
(;[\w/,-]+(=[\w/,-]+)?)* # additional key[=val] elements
)/mx';
$str = 'RRULE:FREQ=WEEKLY;UNTIL=20211231T183000Z;INTERVAL=1;BYDAY=TU,TH
RRULE:FREQ=WEEKLY;WKST=SU;INTERVAL=4;BYDAY=FR
RRULE:FREQ=DAILY;UNTIL=20150628;INTERVAL=3
RRULE:FREQ=DAILY;UNTIL=20150628
RRULE:FREQ=DAILY
RRULE:ABC;DEF=GHI;jkl;abc=999
# negative example
RRULE:
# more examples
DTSTART;TZID=America/New_York:19980101T090000
DTSTART;TZID=America/New_York:AB
DTSTART;TZID=America;more;junk:AB=123;DE=456
DTSTART;TZID=America:AB
DTSTART;junk:ABC=12333
RRULE:FREQ=YEARLY;BYMONTH=4;BYDAY=-1SU;UNTIL=19860427T070000Z
DT;junk;more;junk=junk:ABC;YZO=123
RDATE;VALUE=DATE:20150609,20150611
EXDATE;VALUE=DATE:20150610
RDATE;TZID=America/New_York:19970714T083000
RDATE;VALUE=DATE:19970101,19970120,19970217,19970421
19970526,19970704,19970901,19971014,19971128,19971129,19971225
RRULE:FREQ=YEARLY;UNTIL=20000131T140000Z;BYMONTH=1;BYDAY=SU,MO,TU,WE,TH,FR,SA
BEGIN:VTIMEZONE
TZID:America/New_York
LAST-MODIFIED:20050809T050000Z
BEGIN:DAYLIGHT
DTSTART:19670430T020000
RRULE:FREQ=YEARLY;BYMONTH=4;BYDAY=-1SU;UNTIL=19730429T070000Z
TZOFFSETFROM:-0500
TZOFFSETTO:-0400
TZNAME:EDT
END:DAYLIGHT
BEGIN:STANDARD
DTSTART:19671029T020000
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU;UNTIL=20061029T060000Z
TZOFFSETFROM:-0400
TZOFFSETTO:-0500
TZNAME:EST
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:19740106T020000
RDATE:19750223T020000
TZOFFSETFROM:-0500
TZOFFSETTO:-0400
TZNAME:EDT
END:DAYLIGHT
BEGIN:DAYLIGHT
DTSTART:19760425T020000
RRULE:FREQ=YEARLY;BYMONTH=4;BYDAY=-1SU;UNTIL=19860427T070000Z
TZOFFSETFROM:-0500
TZOFFSETTO:-0400
TZNAME:EDT
END:DAYLIGHT
BEGIN:DAYLIGHT
DTSTART:19870405T020000
RRULE:FREQ=YEARLY;BYMONTH=4;BYDAY=1SU;UNTIL=20060402T070000Z
TZOFFSETFROM:-0500
TZOFFSETTO:-0400
TZNAME:EDT
END:DAYLIGHT
BEGIN:DAYLIGHT
DTSTART:20070311T020000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=2SU
TZOFFSETFROM:-0500
TZOFFSETTO:-0400
TZNAME:EDT
END:DAYLIGHT
BEGIN:STANDARD
DTSTART:20071104T020000
RRULE:FREQ=YEARLY;BYMONTH=11;BYDAY=1SU
TZOFFSETFROM:-0400
TZOFFSETTO:-0500
TZNAME:EST
END:STANDARD
END:VTIMEZONE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);