$re = '/^[0-9].*(be|de)\d{3,5}/m';
$str = '1Ghde345c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);