$re = '/t(?=art)/m';
$str = 'Start to End
Start to End
Start to End again
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);