import Foundation
let pattern = #"^(Fp|Dev)_(.*[^0-9])?[0-9]{1,3}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Dev_xxxxx-1111
Dev_xxxxx-111
1.3.0.0-amd64
Dev_08346f824a146dafbdca4b63eb3ce0b1549c6346_165
Dev_0ab8997f5d45ed6b7515b5148d492c98109bf94a_16
Dev_f64db4c58d6a0eddeec3c12c74d5fbba1849886d_16620
1.3.0.0-amd64
Dev_04938095cc4bcefb1f85d7b306c1c49d335e80ce_167075
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)