import Foundation
let pattern = #"(?<=(?:[^\d]|^))(\d{4}[ \t])(?:\d{4}[ \t]){2}(\d{4})(?=(?:[^\d]|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1234 1234 1234 1234
1234 5678 9101 1121
1234 84848 5454 4888
1111 2222 5555 4444
1111 2222 5555 44444
11111 2222 5555 4444
asa1111 2222 5555 4444dasda
Вчера вечером со счета номер 4301 0234 2145 2140 был совершен перевод на счет 5042 2012 0532 2043 в размере ${payment_amount} рублей
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 **** **** $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)