re = /^(?!.*[A-Za-z].*[A-Za-z].*[A-Za-z])[A-Za-z0-9-]{1,8}$/m
str = '12A-32B
12A-32BC
123456789
123A567B'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end