$re = '/(?<=\/\.)\w+?(?=\s)/';
$str = 'ActivityRecord{7615a77 u0 com.example.grano.example_project/.MainActivity t20}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);