import Foundation
let pattern = #"(?:[^:]+:\/\/)(?:www\.)*([.a-z0-9]+)+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://www.polygon.com/guides/2019/2/22/18225349/tetris-strategy-tips-how-to-jonas-neubauer"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}