const regex = /(?<=^[^-]*\s-\s[^-]*)\S{2}(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^[^-]*\\s-\\s[^-]*)\\S{2}(?!\\S)', 'gm')
const str = `1732 - George Washinton Junior - US president - 1799`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}