#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?<protocol>\w*?):\/\/(?<authority>(?<mnemonic>\w*).(?<host>[\w-.]*))\/(?<path>[\w-]*)\s*$)"
Local $sString = "https://pii.ngkf-qa.commloanservices.com/qa2 " & @CRLF & _
"https://pii.ngkf-qa.pncint.net/qa1 " & @CRLF & _
"https://pii.ngkf-qa.pncint.net/qa2 " & @CRLF & _
"https://pii.rait.commloanservices.com/PII " & @CRLF & _
"https://pii.rait.pncint.net/PII " & @CRLF & _
"https://pii.rait-qa.commloanservices.com/qa1 " & @CRLF & _
"https://pii.rait-qa.pncint.net/qa1 " & @CRLF & _
"https://pii.situs.commloanservices.com/PII " & @CRLF & _
"https://pii.situs.pncint.net/PII " & @CRLF & _
"https://pii.situs-qa.commloanservices.com/qa1 " & @CRLF & _
"https://pii.situs-qa.commloanservices.com/qa2 " & @CRLF & _
"https://pii.situs-qa.pncint.net/qa1 " & @CRLF & _
"https://pii.situs-qa.pncint.net/qa2 " & @CRLF & _
"https://pii.situs-rnd.pncint.net/dev1 " & @CRLF & _
"https://pii.situs-rnd.pncint.net/dev2 " & @CRLF & _
"https://pii.situs-uat.pncint.net/test1 " & @CRLF & _
"https://pii.situs-uat.pncint.net/test2 " & @CRLF & _
"https://pii.suntrust.commloanservices.com/PII " & @CRLF & _
"https://pii.suntrust.pncint.net/pii " & @CRLF & _
"https://pii.suntrust-qa.commloanservices.com/qa1 " & @CRLF & _
"https://pii.suntrust-qa.commloanservices.com/qa2 " & @CRLF & _
"https://pii.suntrust-qa.pncint.net/qa1 " & @CRLF & _
"https://pii.suntrust-qa.pncint.net/qa2 " & @CRLF & _
"https://pii.wd.commloanservices.com/PII " & @CRLF & _
"https://pii.wd.pncint.net/pii " & @CRLF & _
"https://pii.wd-qa.commloanservices.com/qa1 " & @CRLF & _
"https://pii.wd-qa.commloanservices.com/qa2 " & @CRLF & _
"https://pii.wd-qa.pncint.net/qa1 " & @CRLF & _
"https://pii.wd-qa.pncint.net/qa2 " & @CRLF & _
"https://rdt.midlandls.pncint.net/pnclms " & @CRLF & _
"https://rdt.midlandls-qa.pncint.net/pnclms " & @CRLF & _
"https://tci-pnc.pncint.net/ " & @CRLF & _
"https://tci-pnc-qa-pncint.net/ " & @CRLF & _
"https://tci-pnc-rnd.pncint.net/ " & @CRLF & _
"https://tci-pnc-uat.pncint.net/ " & @CRLF & _
"https://wlm.midlandls.pncint.net/ " & @CRLF & _
"https://wlm.midlandls-qa.pncint.net/qa1 " & @CRLF & _
"https://wlm.midlandls-qa.pncint.net/qa2 " & @CRLF & _
"https://wlm-app.midlandls-qa.pncint.net/qa1-fdic " & @CRLF & _
"https://wlm-app.midlandls-qa.pncint.net/qa2fdic "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")