# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^class\d+\K->.*(?=\[[^][]*\];$)/ bit = /gm;t' <<< "class1->Signal = sample1_sample2.sample3_sample4[4:4];
class2->Signal = sample1.sample2.sample3_sample4_sample5[2];
class3->Signal = sample1+sample2_sample3.sample4.sample5sample7[7:3];
class4->Signal = sample1[1]+sample2_sample3.sample4.sample5sample7[7:3];"