re = /(dog)/mi
str = 'I think Ruth\'s dog is cuter DOG than your dog! to Dog to dog.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end