$re = '/@.*?(\..*)$/m';
$str = 'jhony@domain.com
john.doe@company.co.uk
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);