$re = '/^(?=.*?[A-Za-z])(?=.*?[0-9])[0-9A-Za-z]+$/m';
$str = '123swift
swift123
1231
swift';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);