re = /(?<w>){16}
(?<h>){10}
@(?<-w>@|(?<-h>-))+@/mx
str = '@@--@---@@-@-@----@--@-@---@-@@-@-@-@@-@-@-@----@-@-@-@-@-@-@-@--@-@-@-@---@-@@-@--@--@--@----@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end