$re = '/^\h*cat\h+<<(?!<)(.*)/m';
$str = 'cat << EOF
cat <<EOF
cat <<<EOF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);