$re = '/(https?:\/\/)?(www.website.com)(\/)?(?!team|forum)(\w)*/m';
$str = 'https://www.website.com/team
www.website.com
www.website.com/alsdjflasd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);