re = /"([^"]+)"(?= keyword)/m
str = '"ignore this" blah "ignore this" blah "capture this" keyword "ignore this" blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end