re = /^(?:(?:00|\+)?45)?(?=2|3[01]|4[012]|4911|5[0-3]|6[01]|[78]1|9[123])\d{8}$/m
str = '004571000574
4511760574
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end