$re = '/\d{2}(?=\d{4}\W)/m';
$str = '12345678
123456
poiuu4
b234567nb ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);