use strict;
my $str = 'Anagram
Assassination
Abaca
abba
abbb
aa bb aaa';
my $regex = qr/^[^aA\n]*[aA][^aA\n]*[aA][^aA\n]*[aA].*$/mp;
my $subst = '§';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";