const regex = /(?<=^\*\s*Reference\s*:)(?:.(?!^\*))*/ms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^\\*\\s*Reference\\s*:)(?:.(?!^\\*))*', 'ms')
const str = `*Reference: https://docs.google.com/document/d/1FFTgytIIcMYnCCgp2cKuUWIwdz7MFolLzCci_-OQn9c/edit#heading=h.81ay6ysgrxtb
https://docs.google.com/document/d/1FFTgytIIcMYnCCgp2cKuUWIwdz7MFolLzCci_-OQn9c/edit#heading=h.81ay6ysgrxtb
*Citation: rg
-----------------------------------------------------------------
*Reference:
*Citation: rg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}