import re
regex = re.compile(r"^-?[0-9]+$", flags=re.MULTILINE)
test_str = ("0\n"
"00\n"
"0000000000\n"
"0123456789\n"
"X0123456789\n"
"01234X56789\n"
"0123456789X\n\n"
"1\n"
"11\n"
"1111111111\n"
"1000000000\n"
"0000000001\n"
"1234567890\n"
"X1234567890\n"
"12345X67890\n"
"1234567890X\n\n"
"2\n"
"22\n"
"2222222222\n"
"2000000000\n"
"0000000002\n"
"2345678901\n"
"X2345678901\n"
"23456X78901\n"
"2345678901X\n\n"
"3\n"
"33\n"
"3333333333\n"
"3000000000\n"
"0000000003\n"
"3456789012\n"
"X3456789012\n"
"34567X89012\n"
"3456789012X\n\n"
"4\n"
"44\n"
"4444444444\n"
"4000000000\n"
"0000000004\n"
"4567890123\n"
"X4567890123\n"
"45678X90123\n"
"4567890123X\n\n"
"5\n"
"55\n"
"5555555555\n"
"5000000000\n"
"0000000005\n"
"5678901234\n"
"X5678901234\n"
"56789X01234\n"
"5678901234X\n\n"
"6\n"
"66\n"
"6666666666\n"
"6000000000\n"
"0000000006\n"
"6789012345\n"
"X6789012345\n"
"67890X12345\n"
"6789012345X\n\n"
"7\n"
"77\n"
"7777777777\n"
"7000000000\n"
"0000000007\n"
"7890123456\n"
"X7890123456\n"
"78901X23456\n"
"7890123456X\n\n"
"8\n"
"88\n"
"8888888888\n"
"8000000000\n"
"0000000008\n"
"8901234567\n"
"X8901234567\n"
"89012X34567\n"
"8901234567X\n\n"
"9\n"
"99\n"
"9999999999\n"
"9000000000\n"
"0000000009\n"
"9012345678\n"
"X9012345678\n"
"90123X45678\n"
"9012345678X\n\n"
"-0\n"
"-00\n"
"-0000000000\n"
"-0123456789\n"
"-X0123456789\n"
"-01234X56789\n"
"-0123456789X\n\n"
"-1\n"
"-11\n"
"-1111111111\n"
"-1000000000\n"
"-0000000001\n"
"-1234567890\n"
"-X1234567890\n"
"-12345X67890\n"
"-1234567890X\n\n"
"-2\n"
"-22\n"
"-2222222222\n"
"-2000000000\n"
"-0000000002\n"
"-2345678901\n"
"-X2345678901\n"
"-23456X78901\n"
"-2345678901X\n\n"
"-3\n"
"-33\n"
"-3333333333\n"
"-3000000000\n"
"-0000000003\n"
"-3456789012\n"
"-X3456789012\n"
"-34567X89012\n"
"-3456789012X\n\n"
"-4\n"
"-44\n"
"-4444444444\n"
"-4000000000\n"
"-0000000004\n"
"-4567890123\n"
"-X4567890123\n"
"-45678X90123\n"
"-4567890123X\n\n"
"-5\n"
"-55\n"
"-5555555555\n"
"-5000000000\n"
"-0000000005\n"
"-5678901234\n"
"-X5678901234\n"
"-56789X01234\n"
"-5678901234X\n\n"
"-6\n"
"-66\n"
"-6666666666\n"
"-6000000000\n"
"-0000000006\n"
"-6789012345\n"
"-X6789012345\n"
"-67890X12345\n"
"-6789012345X\n\n"
"-7\n"
"-77\n"
"-7777777777\n"
"-7000000000\n"
"-0000000007\n"
"-7890123456\n"
"-X7890123456\n"
"-78901X23456\n"
"-7890123456X\n\n"
"-8\n"
"-88\n"
"-8888888888\n"
"-8000000000\n"
"-0000000008\n"
"-8901234567\n"
"-X8901234567\n"
"-89012X34567\n"
"-8901234567X\n\n"
"-9\n"
"-99\n"
"-9999999999\n"
"-9000000000\n"
"-0000000009\n"
"-9012345678\n"
"-X9012345678\n"
"-90123X45678\n"
"-9012345678X\n\n"
"X\n"
"Y\n"
"Z")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")