$re = '/(?=@~@(.+?)@~@)/m';
$str = '@~@item1@~@blablablablablabla;@~@item2@blablablablablablabla;@~@item3@~@blabla#####
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);