$re = '/\(([^()]+)\)|\h+/m';
$str = 'Huawei MatePad 11 (2021)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);