$re = '/^(.+\s-\s\w{2})$|^(Total\s\d{1,5}:.+)$/m';
$str = 'Total
2015
DOLLAR
AMOUNT
Oct-15 DIFF 15-16
Total
2015
COMPANY 1 - WI
Nuts $ 59.85 $ 0.00 $ 135.45 $ 0.00 $ 135.45 $0.00
Bolts $ 0.00 $ 0.00 $ 0.00 $ 0.00 $ 0.00 $0.00
Screws $ 449.20 $ 0.00 $ 541.23 $ 0.00 $ 541.23 $0.00
Total 7765: $ 509.05 $ 0.00 $ 676.68 $ 0.00 $ 676.68 $0.00
Company 2 - NE
Nuts $ 0.00 $ 0.00 $ 0.00 $ 0.00 $ 0.00 $0.00
Bolts $ 0.00 $ 55.67 $ 542.48 $ 719.82 $(177.34) $777.02
Total 1876: $ 0.00 $ 55.67 $ 2,960.52 $ 4,265.82 $(1,305.30) $5,854.60
Company 3 - MN
Nuts $ 109.52 $ 606.52 $ 858.36 $ 606.52 $ 251.84 $606.52
Paper $ 0.00 $ 0.00 $ 483.82 $ 0.00 $ 483.82 $678.30
Gas $ 0.00 $ 0.00 $ 0.00 $ 0.00 $ 0.00 $0.00
OTHER $ 521.49 $ 0.00 $ 521.49 $ 0.00 $ 521.49 $0.00
Total 6524: $ 631.01 $ 606.52 $ 3,909.09 $ 606.52 $ 3,302.57 $1,284.82
Company 4 - IA
Anything $ 0.00 $ 0.00 $ 0.00 $ 0.00 $ 0.00 $0.00
Other $ 0.00 $ 0.00 $ 171.90 $ 0.00 $ 171.90 $0.00
Total 1123: $ 0.00 $ 0.00 $ 171.90 $ 0.00 $ 171.90 $0.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);