#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\b\w++::\w++\s*+\(|\G(?<!^))\s*+(\w++)\s*+(?:\[[^]]*+]\s*+)?,"
Local $sString = "Not even sure how to attack this Regex Need (Multiline text with extraction of library names)" & @CRLF & _
"" & @CRLF & _
"Sample Text" & @CRLF & _
"" & @CRLF & _
" box::use(" & @CRLF & _
" DBI[dbListTables, dbExecute]," & @CRLF & _
" Yessir[this_one, that one," & @CRLF & _
" and_this_one]," & @CRLF & _
" Maybesir[" & @CRLF & _
" func_one," & @CRLF & _
" func_two," & @CRLF & _
" ]," & @CRLF & _
" Nosir," & @CRLF & _
" " & @CRLF & _
" database = logic/database," & @CRLF & _
" log = logic/log," & @CRLF & _
" options = logic/options," & @CRLF & _
" utilities = logic/utilities," & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
"I would like to have a regexp which matches the following from the above text:" & @CRLF & _
"" & @CRLF & _
" DBI, Yessir, Maybesir, Nosir" & @CRLF & _
"" & @CRLF & _
"Is there an easy way to approach this? I have been trying to use the regexp101 website to help me out here, but this one is sufficiently complex that I am a bit out of my depth. My current line is the following:" & @CRLF & _
"" & @CRLF & _
" box::use\(\n(?:[\s]*([A-Za-z0-9]*)(?:[A-Za-z0-9\[\]_\ ,]*\n))" & @CRLF & _
"" & @CRLF & _
"But, this is of course not getting it. I am not sure how to handle getting the multiple (unknown how many there really would be) libraries inside the box::use function." & @CRLF & _
"" & @CRLF & _
"It might be easier to extract the text from inside the use::box function first and then regexp that?" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"Edit: Forgot to add that I am using Python3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")