re = /(?=.*[}{,.^?~=+\-_\/*\-+.\|])(?=.*[a-zA-Z])(?=.*[0-9]).{8,}/m
str = '9,1 4a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end