re = /(?:(?:\/\*(?:[^*]|(?:\*+[^*\/]))*\*+\/)|(?:(?<!\:|\\\|\'|\")\/\/.*))/m
str = '<script>
// This is a comment
/* This is another comment */
// The following is not a comment
var src="//google.com";
</script>
<img src="data:image/jpeg;base64,/9j/4AAQSkZJRgABAQAAAQABAAD/2wBDAAgGBgcGBQgHBwcJCQg//ejhdbjkebdklebdklenbdknedklnekdlelde>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end