package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(ab.*?cd)`)
var str = `start ab0 ab1 ab2 cd kkkk cd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}