package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^/]{0,7})$`)
var str = `page`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}