using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:(?:(?!"")[^|\r\n]*|""[^""\r\n]*""(?:(?=$)|(?=\|)(?!(?:\|[^|""\r\n]*)+[^|\r\n]"")))(?:$|\|))*+)("")";
string substitution = @"$1\\$2";
string input = @"123|110092|ACCT|""HC Account""|""Account1||||||||||||""Mary""|||""|""||||132|""STE|504""|1253|Unspecified Account|||N||ACTV|Active||||04/30/2013|12/31/2099|||||||||||||
123|110092|ACCT|""HC Account""|""Account1||||||||||||""|Mary""|||""|""||||132|""STE|504""|1253|Unspecified Account|||N||ACTV|Active||||04/30/2013|12/31/2099|||||||||||||
123|110092|ACCT|""HC Account""|""Account1||||||||||||""|Mary|""|||""|""||||132|""STE|504""|1253|Unspecified Account|||N||ACTV|Active||||04/30/2013|12/31/2099|||||||||||||
123|110092|ACCT|""HC Account""|""Account1||||||||||||""Mary|""|||""|""||||132|""STE|504""|1253|Unspecified Account|||N||ACTV|Active||||04/30/2013|12/31/2099|||||||||||||";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}