using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http(s|):\/\/([a-z0-9-\.]+|)+[a-z0-9-]+\.[a-z]+\/adManager\/(css|js)\/[A-z]+\.(css|js)$";
string input = @"https://cdn.ndsoft.co.kr/js/jquery.modal.min.js";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}