package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\,[\n|\s]*\])|(\,[\n|\s]*\))`)
var str = `,
]
,]
,
sasd
]
,
]
,)
,
)
,asd)
, )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}