$re = '/\d+\s[a-zA-Z0-9]+/i';
$str = '034535 sfdskdsjfhs34f3f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);