$re = '/-\K[^-]{7,8}$/m';
$str = 'game-when-no-one-at-xhU8c0dL
coins-at-the-desk-1xhz83c
example-example-1391340';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);