$re = '/(\/Inventory\/AddCar)|(\/Inventory\/AddTruck)|(\/Inventory\/AddBike)/m';
$str = '/Inventory/AddTruck
/Inventory/AddBike
/Inventory/AddCar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);