re = /[a-zA-Z0-9!#$%&'*+\/=?^_`{|}~-]+(?:.[a-zA-Z0-9!#$%&'*+\/=?^_`{|}~-]+)*@(?:[a-zA-Z0-9](?:[a-zA-Z0-9-]*[a-zA-Z0-9])?.)+[a-zA-Z0-9](?:[a-zA-Z0-9-]*[a-zA-Z0-9])?/
str = ' string << \'"Test test Real Estate - Test\\\'s International Real Estate" <test@test.com>\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end