package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)__typename":"GraphImage","id":"(.*?)","edge_media_to_caption":{"edges":\[{"node":{"text":"(.*?)"}}]},"shortcode":"(.*?)","edge_media_to_comment":{"count":(.*?)},"comments_disabled":false,"taken_at_timestamp":(.*?),"dimensions":{"height":(.*?),"width":(.*?)},"display_url":"(.*?)","edge_liked_by"`)
var str = `/27891564_190819718336556_2731792619813208064_n.jpg?_nc_ht=instagram.fdel1-4.fna.fbcdn.net","requested_by_viewer":false,"username":"ziynetaki","connected_fb_page":null,"edge_felix_video_timeline":{"count":0,"page_info":{"has_next_page":false,"end_cursor":null},"edges":[]},"edge_owner_to_timeline_media":{"count":4,"page_info":{"has_next_page":false,"end_cursor":null},"edges":[{"node":{"__typename":"GraphImage","id":"1998193948597745904","edge_media_to_caption":{"edges":[{"node":{"text":"test"}}]},"shortcode":"Bu7As8ygPjw","edge_media_to_comment":{"count":0},"comments_disabled":false,"taken_at_timestamp":1552423302,"dimensions":{"height":216,"width":320},"display_url":"https://instagram.fdel1-4.fna.fbcdn.net/vp/b26fc82649aebaba80ff8750844d9476/5D32EFAE/t51.2885-15/e35/52508202_381950182383672_2887085630092404003_n.jpg?_nc_ht=instagram.fdel1-4.fna.fbcdn.net","edge_liked_by":{"count":6},"edge_media_preview_like":{"count":6},"location":null,"gating_info":null,"media_preview":"ACoc6SiiigAooooAKKKKACiiigAooooAKKKKAP/Z","owner":{"id":"7101789977","username":"ziynetaki"},"thumbnail_src":"https://instagram.fdel1-4.fna.fbcdn.net/vp/7d5606659a99d7a3b8f4d941f8d33a19/5D171D3A/t51.2885-15/e35/c52.0.216.216,"p":{"show_feedback":"false"}},"igwspe":{"g":"has_sensitivity_screen","p":{"has_stories_sensitivity_screen":"true"}},"0":{"p":{"0":false,"1":false,"2":false},"qex":true},"2":{"p":{"0":false},"qex":true},"3":{"p":{"0":false},"qex":true},"4":{"p":{"0":false},"qex":true},"5":{"p":{"0":false},"qex":true}},"probably_has_app":true},"rollout_hash":"01e70cf96366","bundle_variant":"es6","is_canary":false};</script>
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}