# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"dog123\",\n(( +\"[\w\d]+\",\n)+ +)\"cat123\""
test_str = ("{\n"
" \"items\": [\n"
" {\n"
" \"tableName\": \"Table0\",\n"
" \"count\": 2,\n"
" \"columnNames\": [\n"
" \"dog123\",\n"
" \"referenceNumber\",\n"
" \"account_id\",\n"
" \"first\",\n"
" \"last\",\n"
" \"street\",\n"
" \"city\",\n"
" \"name\",\n"
" \"name\",\n"
" \"postalCode\",\n"
" \"address\",\n"
" \"number\",\n"
" \"dob\",\n"
" \"lookupName\",\n"
" \"address\",\n"
" \"lookupName\",\n"
" \"lookupName\",\n"
" \"lookupName\",\n"
" \"cat123\",\n"
" \"awareness_date\",\n"
" \"patient_description\",\n"
" \"date_of_issue\",\n"
" \"lookupName\",")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.