#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*([:,.])\s*(?!<br />)"
Local $sString = "Composition:80% Polyamide, 15% Elastane, 5% Wool." & @CRLF & _
"Side length 50.5 cm <---- THIS SHOULDN'T BE MATCHED" & @CRLF & _
"Value 4,500 <---- THIS SHOULDN'T BE MATCHED EITHER" & @CRLF & _
"" & @CRLF & _
"ό,τι <---- THIS IS A FIXED PHRASE IN GREEK AND THEREFORE SHOULDN'T BE MATCHED" & @CRLF & _
"Comfort and timeless design characterize the Puma Smash V2 made of suede leather. They can be worn all the time ,being a unique choice for those who want to stand out .Made of rubber.<br />- Softfoam floor<br />- Binding with laces" & @CRLF & _
"" & @CRLF & _
"Specs:<br />• Something<br /><br />• Something else<br />• One more" & @CRLF & _
"" & @CRLF & _
"Children's Form Champion<br /><br />Children's set that will give a comfortable feeling for endless hours of play.<br />It consists of a cardigan and trousers ,made of soft fabric and have rib cuffs and legs for a better fit.<br /><br />• Normal fit<br /><br />• Cardigan :Rib cuffs, zippers throughout length, high neck, Champion logo <br /> <br />• Pants: Elastic waist with drawstring, ribbed legs, Champion logo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")