$re = '/(?=[a-z]{0,3}\*)(?=\*{0,3}[a-z])[a-z*]{2,4}/m';
$str = '124 adbaad aa1 efd f*ad *** af 848';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);