// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<hi>((.|\n)*?)</hi>").unwrap();
let string = "<hi>
Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Aenean tincidunt diam sit amet semper vestibulum. Donec dictum dapibus magna vitae pharetra. Fusce condimentum velit at tempus aliquam. Maecenas maximus scelerisque nisi, et gravida felis molestie quis. Nunc nec mauris in ligula imperdiet rhoncus. Donec dignissim magna eu consectetur luctus.
Phasellus sed massa vitae nisl congue congue. Etiam nec luctus dolor, eget placerat ligula. Fusce mollis neque vitae fermentum gravida. Suspendisse maximus felis risus, vel fringilla mauris tristique quis. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Interdum et malesuada fames ac ante ipsum primis in faucibum
</hi>
Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Aenean tincidunt diam sit amet semper vestibulum. Donec dictum dapibus magna vitae pharetra. Fusce condimentum velit at tempus aliquam. Maecenas maximus scelerisque nisi, et gravida felis molestie quis. Nunc nec mauris in ligula imperdiet rhoncus. Donec dignissim magna eu consectetur luctus. Phasellus sed massa vitae nisl congue congue. Etiam nec luctus dolor, eget placerat ligula. Fusce mollis neque vitae fermentum gravida. Suspendisse maximus felis risus, vel fringilla mauris tristique quis. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Interdum et malesuada fames ac ante ipsum primis in faucibus.
<hi>
Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Aenean tincidunt diam sit amet semper vestibulum. Donec dictum dapibus magna vitae pharetra. Fusce condimentum velit at tempus aliquam. Maecenas maximus scelerisque nisi, et gravida felis molestie quis. Nunc nec mauris in ligula imperdiet rhoncus. Donec dignissim magna eu consectetur luctus.
Phasellus sed massa vitae nisl congue congue. Etiam nec luctus dolor, eget placerat ligula. Fusce mollis neque vitae fermentum gravida. Suspendisse maximus felis risus, vel fringilla mauris tristique quis. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Interdum et malesuada fames ac ante ipsum primis in faucibum
</hi>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}