package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(address|notes)='((?:\\\'|[^'])*)`)
var str = `address='St Marks Church',notes='The North East\'s premier...'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}