$re = '/(address|notes)=\'\K.*?(?=(?<!\\\\)\')/';
$str = 'address=\'St Marks Church\',notes=\'The North East\\\'s premier...\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);