$re = '/^(\S+) +<(?!\1)[^>]*>$/m';
$str = 'Louis Vuitton <yjfner@stangpedemc.com>
Louis Vuitton <yjfner@stangpedemc.com>
yjfner@stangpedemc.com <yjfner@stangpedemc.com>
ABC @ CDE <yjfner@stangpedemc.com>
"Valid Name" <yjfner@stangpedemc.com>
ValidName <yjfner@stangpedemc.com>
Valid@Name <yjfner@stangpedemc.com>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);