import re
regex = re.compile(r"^.+?(?=(?:\d\d )+)", flags=re.MULTILINE)
test_str = ("[ABC TEST] CNT(1) S(0) 00 00 12 34 12 34 12 34 .....\n"
"[ABC TEST] CNT(2) S(0) 00 12 34 56 78 88 12 12 .....")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)